Aqua One Moray 700 Internal Filter - Loses flow very quickly

Arthur1993

Hello,

I have a 110 litre (29 US Gallons) Aqua One Oak Style tank setup. I installed the filter and heater that came with the tank. However, the filter, Aqua One Moray 700 Internal Filter, doesn't seem very good to me and I was wondering whether anyone else has had similar experiences of it. I seem to need to clean it out every few days because it gets gunked up and the flow rate slows to barely a trickle, often less than a week after the last cleaning. I put it in a pair of tights this time round in the hope that they would keep the worst of the gunk out, and this seemed to work initially, with the flow rate staying high. This morning, however, it has diminished quite a lot and I know I'll need to clean it again before the weekend if I want the flow rate to be reasonable. Added to this, the tank water is often cloudy, and gets worse after a cleaning. I suspect the cloudiness to be a bacterial bloom, which I am worried means I am losing a lot of my bacteria each time I clean the filter media, even though I only used tank water to do so.

My tank has been running for about six months. I test the water weekly and the levels are usually good, with occasionally high nitrate levels. It is fairly heavily planted with vallis, anubias, java moss, java fern, and Rotala Rotundifolia indica. I have driftwood and rocks. The inhabitants are 1 Dwarf Gourami, 4 Honey Gouramis, 13 Neon Tetras, and a colony of Red Cherry Shrimp. There is also a population of pond snails, and some assassin snails to try and keep them in check! Both the cherry shrimp and assassin snails, are breeding quite regularly.

My other tank is a Fluval Flex, with which I have none of these problems and it has made me wonder whether the Aqua One filter just isn't any good. It's certainly a lot smaller than the filtration system in my smaller Fluval.

So as a last question, and sorry for the long post, does anyone have any filters they would recommend for a 110 litre (29 US Gallons) tank?

Thanks for any help!
 

LouPey

I have the same filter and tank and haven't had any problems *touch wood! * albeit mine has only been running 3 months.
Do you wash out the propeller when you do the 6-8 week carbon filter change?

Also regarding a different filter I was thinking of a fluval '07 external filter (only because I find the moray 700 bulky and fiddly to change as I struggle to get the plus through the small holes st the back top of the tank.
 
Upvote 0

Similar Aquarium Threads

Replies
1
Views
258
Coradee
  • Question
Replies
2
Views
228
GlennO
Replies
5
Views
469
Cichlidude
Replies
14
Views
892
PETS BEST FRIEND
Replies
3
Views
209
Daeraizover

Random Great Thread!

New Aquarium Filter Threads

Top Bottom