Help Anubias nana help

ToastedRice235

New Member
Member
Messages
15
Reaction score
1
I noticed that my Anubias Nana plant that o recently added has a white fuzzy thing on it. What caused it and how can I help?
20200604_231707.jpg
Thanks
 

LadfromLondon

Well Known
Member
Messages
740
Reaction score
520
Location
London, UK
I think it’ll make a good snack for some snails! I’m pretty sure it’s hair algae which is because it’s newly added to the tank :)
 

julifhy

Well Known
Member
Messages
1,376
Reaction score
1,917
Location
Bay Area
Experience
Just started
My anubias had the same thing, but after a while it disappeared. I'm not sure what it was though. I just assumed it was a part of the plant.
 
  • Thread starter
  • Thread Starter
  • #5
OP
ToastedRice235

ToastedRice235

New Member
Member
Messages
15
Reaction score
1
TW2AQUATICS said:
I think it’ll make a good snack for some snails! I’m pretty sure it’s hair algae which is because it’s newly added to the tank :)
Thanks, I thought my plant was a on its way to become a goner
 

julifhy

Well Known
Member
Messages
1,376
Reaction score
1,917
Location
Bay Area
Experience
Just started
TW2AQUATICS said:
Haha not at all! I’d commend you if you managed to kill an Anubias ;)
Unfortunately I've managed to (maybe) kill my anubias :sorry:
My gold coin anubias is melting :(. It's still green, but also very "floppy".
 

LadfromLondon

Well Known
Member
Messages
740
Reaction score
520
Location
London, UK
julifhy said:
Unfortunately I've managed to (maybe) kill my anubias :sorry:
My gold coin anubias is melting :(. It's still green, but also very "floppy".
Oh no! Is that the same as an Anubias Nana Gold? I just bought one and I’m yet to attach it to my Cholla wood-It’s not arrived yet :Have you used any liquid fert for it?
 

julifhy

Well Known
Member
Messages
1,376
Reaction score
1,917
Location
Bay Area
Experience
Just started
TW2AQUATICS said:
Oh no! Is that the same as an Anubias Nana Gold? I just bought one and I’m yet to attach it to my Cholla wood-It’s not arrived yet :Have you used any liquid fert for it?
I don't think it's the same and no I haven't. I don't have any fertilizer or lighting for it, so I think that could of been the problem. I also didn't attach it to drift wood, so that could of been the another problem. I assumed it would be just fine in gravel since my other anubias is thriving in gravel. I'm not sure it will recover, but I really hope it does.
 

LadfromLondon

Well Known
Member
Messages
740
Reaction score
520
Location
London, UK
julifhy said:
I don't think it's the same and no I haven't. I don't have any fertilizer or lighting for it, so I think that could of been the problem. I also didn't attach it to drift wood, so that could of been the another problem. I assumed it would be just fine in gravel since my other anubias is thriving in gravel. I'm not sure it will recover, but I really hope it does.
Hope it all goes well! :)
 

New Threads

Similar Threads

Follow FishLore!

FishLore on Social Media

Online statistics

Members online
215
Guests online
3,727
Total visitors
3,942

Aquarium Photo Contests

Aquarium Calculator

Top Bottom