Algae problems

Mikel88
Member
Hello, I have a 37 gallon tank with 2 Java ferns and an Anubias. I have more plants coming in a few days. The Fertilizer I am using is from Aquarium CO OP. I leave my lights on for 7 hours a day by using a timer. Turns on at 8am to noon. Than turns off until 4. On for another 3 hours. I added 3 nerite snails almost a week ago and they have been doing well with the brown algae. I also have 1 oto that is doing fine. Use to have more but lost 2 of them due to ick. Issue I am having is green algae. Its growing fast. Curious if I should do less light or perhaps buy a better light. The stock one is not that great. My water parameters are good. Nitrates are only around 10. Thank you! Picture below
 
SanDiegoRedneck
Member
Mikel88 said:
Hello, I have a 37 gallon tank with 2 Java ferns and an Anubias. I have more plants coming in a few days. The Fertilizer I am using is from Aquarium CO OP. I leave my lights on for 7 hours a day by using a timer. Turns on at 8am to noon. Than turns off until 4. On for another 3 hours. I added 3 nerite snails almost a week ago and they have been doing well with the brown algae. I also have 1 oto that is doing fine. Use to have more but lost 2 of them due to ick. Issue I am having is green algae. Its growing fast. Curious if I should do less light or perhaps buy a better light. The stock one is not that great. My water parameters are good. Nitrates are only around 10. Thank you! Picture below
How often do you dose with plant food?

Maybe cut back a little. There is enough food for growing plants PLUS enough to support algae bloom.
 
  • Thread Starter
Mikel88
Member
SanDiegoRedneck said:
How often do you dose with plant food?

Maybe cut back a little. There is enough food for growing plants PLUS enough to support algae bloom.
I follow the instructions on the bottle. Says pump once for 10 gallon of water. I usually do 3 pumps once a week. I'll try bi weekly. My tap water has enough nitrates so that should help
 

Random Great Thread

Latest threads

Top Bottom