Adding New Fish During Water Change?

  1. THE HABITAT

    THE HABITAT Well Known Member Member

    Wondering if it is a bad idea to my usual water change and add a couple new fish in the same day....later on after the water settles of course....
     
  2. Katie13

    Katie13 Fishlore VIP Member

    I have done this multiple times. I tend to do them before, but depending on the condition of the fish, I have done it a few times after.
     
  3. OP
    OP
    THE HABITAT

    THE HABITAT Well Known Member Member

    I appreciate the feedback but i think i may hold off a lil longer till i can get my cloudy water under control...i checked my water last night and ammonia was 0 nitrite was 0 and nitrate was 20....still don't understand why it hasn't cleared up yet...it happened after a water change and filter changes and i thought i may have messed up my cycle but all my parameters have been staying where i previously mentioned...possibly slightly overfeeding...will give it a little more time and continue my water change routine and parameter checks....sorry for jumping off the subject...
     


  4. Katie13

    Katie13 Fishlore VIP Member

    If you can post a picture, I might be able to help.
     
  5. OP
    OP
    THE HABITAT

    THE HABITAT Well Known Member Member

    i took a couple pics but they will not really show the " haze" in the water...i'll ride it out a little longer and keep the lights on for a little less time as it appeared i had an algae bloom from my Finnex 24/7 planted plus...
     
  6. Katie13

    Katie13 Fishlore VIP Member

    My first thought was either an algae bloom or a bacteria bloom. Good luck!
     
  7. OP
    OP
    THE HABITAT

    THE HABITAT Well Known Member Member

    but the thing that threw me off is i did water changes in my 55 and my 8.8 and they both showed the same sign of a slight haze and i also tested my tap water and those reading were also good...havn't done a water change on my 10 yet as its a little on the newer side it is cycled its reading are also good and its the home to my 3 guppy a ramshorn and a small handful of guppy fry
     
  8. Fashooga

    Fashooga Fishlore VIP Member

    Did you do something to the filter like run it under tap water instead of tank water? Did you forget to put like a conditioner in there
     
  9. OP
    OP
    THE HABITAT

    THE HABITAT Well Known Member Member

    I did use prime in both after my water change but i changed the filters instead of rinsing them...my 55 has 2 cartridges and i changed both and the 8.8 i replaced my cartridge with poly fil....thats why i thought i messed my cycle up but all my reading were normal...from now on i will be rinsing my media in tank water instead of changing them...they get expensive