Ac70. Breaking?

Sanderguy777
  • #1
I have a 60 gallon freshwater tank and I decided to get an ac70 in addition to my penguin 350. The penguin was getting noisy so I wanted to replace it with 2 ac70s.
I got them but I only put one on so the cycle wouldn't get messed up.
So, yesterday I cleaned the tank and about 4 hrs later I noticed the ac70 was not running. Took it apart and found 1 piece of sand in the impeller. (I don't have clownfish so I don't understand ) it had stopped the impeller and the motor was going for who knows how long.
Now the penguin is silent except for the water, and the ac70 is working but sounds like it's grinding. It was doing this before the sand got in it, but I don't know if that is normal.

So, should I take it back? Should it have been making that noise brand new?
Will the sand have hurt it?
 
Mike1995
  • #2
might have done some damage to the impeller.
 
Sanderguy777
  • Thread Starter
  • #3
All I could see is a bit of scoring on the magnet. But as I said, it made the noise before....
 
david1978
  • #4
Contact their customer service. They were really good years ago hopefully they still are. I broke the housing on my 110 so I called them to see if I could just buy the housing. Lady said they just don't break and it probably was a defect. They sent me a whole new filter since it was still under factory warranty.
 
Travis Bradbury
  • #5
Ive had this issue on my 110 for awhile.. after days of plastering vaseline, still a grinding noise. I too have sand, and had lotsss in it. 1 grain won't do much. Eventually it just went away. Let it run for abit to get its own type of lube on there where its needed (algae) but afew tricks ive found is there turning it on and off afew times seemed to help with the noise. I even do it now for air bubbles every time I WC, otherwise id hear the water inside the pump because of the air bubbles in it
 
Sanderguy777
  • Thread Starter
  • #6
Ok. I will try it. Can you explain exactly how you do it? Unplug it, leave it off so long, plug in for so long, unplug again, etc.


I plan to get intake sponges for all my filters.

I can return it to the store, but should I go through customer service? PetSmart has been pretty good with other stuff.
 
david1978
  • #7
You could try. Iv never dealt with petsmart. I was looking for parts and wasn't sure if they were available that's why I called them.
 
Juicetin1314
  • #8
Ive had this issue on my 110 for awhile.. after days of plastering vaseline, still a grinding noise. I too have sand, and had lotsss in it. 1 grain won't do much. Eventually it just went away. Let it run for abit to get its own type of lube on there where its needed (algae) but afew tricks ive found is there turning it on and off afew times seemed to help with the noise. I even do it now for air bubbles every time I WC, otherwise id hear the water inside the pump because of the air bubbles in it

Ive found that it will clear the air bubbles itself if you put it on the highest flow setting and pull the media basket up to free up the water flow momentarily. Might be a little easier than unplugging it if that helps any.

to the OP, are you hearing grinding? or is the pump just cavitating due to air stuck in the intake? try letting the pump prime itself by removing the media basket for a minute or two and see if it quiets down.
 
Sanderguy777
  • Thread Starter
  • #9
I hear it grinding. There is nothing in it, but it sounds like it.

I let it clear the air itself. It takes WAY longer than my 350, but is clear of bubbles in about 2 or 3 minutes. I will try letting it work without the filter media next time.

I will try to get it returned Monday. In the meantime, I can ask Fluval customer service about it.
 
Sanderguy777
  • Thread Starter
  • #10
Update: I got another one and plugged it it. It is MUCH quieter than the old one was. The old one has quieted down a bit but is still not quiet.
The media basket on the new one was rattling against the housing, but I jiggled it till it stopped.
All old media in the new one and its as quiet as the water flowing into the tank.

Old one is going to be returned.
 
Juicetin1314
  • #11
Glad to hear you got it sorted.
 

Similar Aquarium Threads

  • Locked
Replies
10
Views
1K
leeishom
Replies
10
Views
1K
SallImSayin
Replies
10
Views
222
Rye3434
  • Locked
Replies
14
Views
880
catsma_97504
  • Locked
Replies
11
Views
2K
Sanderguy777
Top Bottom