Recent content by Brihhtuhknee - Page

  1. B

    Fish flashing but no ich?

    I’ve noticed my fish have started flashing on driftwood, plants, substrate occasionally but I am not seeing any signs of white spots anywhere or ich. Water parameters also seem completely normal as well. Any ideas what else could be causing this? Tank size: 40 gal breeder, cycled Parameters...
  2. B

    Cloudy water during initial cycle

    Ah so good to know! I’m still figuring this all out lol thanks!
  3. B

    Cloudy water during initial cycle

    It’s definitely more green. I’ve been leaving them on from around 7:30am to about 9/9:30pm. I’m assuming that’s probably too much?
  4. B

    Cloudy water during initial cycle

    Hello! I’m currently in week 3ish of cycling this 40 gal breeder without fish and over the last 3-4 days the water is just getting more and more cloudy. I haven’t done any water changes or much of anything other than added a few live plants. Is this a normal part of the cycling process, algae...
  5. B

    Does my tank have enough support?

    Wonderful, thanks so much!
  6. B

    Does my tank have enough support?

    Shoot, okay. Would placing a piece of wood under the tank the exact dimensions of the tank help? Or should I look for a new solution all together?
  7. B

    Does my tank have enough support?

    Hi everyone, new here! I set up this 40gal breeder a little over a week ago and although what I am using as a stand is very sturdy, I’m beginning to worry not having support on the front and back edges might cause an issue. Thoughts?
Top Bottom